2016年1月7日木曜日

マジか!とうとう来週IE8・9・10が公式サポート終了するとか!

マジすか!?

MicrosoftがブラウザInternet Explorer 8・9・10のサポートを2016年1月12日に打ち切ると発表しました。この日以降はセキュリティアップデートを含めたすべてのアップデートが行われないようになります。
Internet Explorer End of Supporthttps://www.microsoft.com/en-us/WindowsForBusiness/End-of-IE-support
Internet Explorer 8, 9 and 10 die on Tuesdayhttp://thenextweb.com/microsoft/2016/01/05/web-developers-rejoice-internet-explorer-8-9-and-10-die-on-tuesday/
Microsoftは2016年1月12日(日本時間の1月13日)に予定しているWindows Updateを最後に、Internet Explorer 8・9・10の公式サポートを終了します。これ以降は、Internet Explorer 11が唯一サポートを受けられるInternet Explorerになります。
なお、Windows Update内で配布される更新プログラム「KB3123303」にはInternet Explorerの警告メッセージ表示機能があり、サポートが終了したInternet Explorerを使用している場合に警告メッセージが出るとのこと。警告メッセージの詳細な内容は今のところ不明ですが、適宜、警告メッセージでInternet Explorer 11やMicrosoft Edgeへの移行を促すものと見られます。

ついに・・・この日が来てしまったのか!
IE8、9、10が正式にサポートの対象外になってしまうんだ。
IE10って最近のブラウザのような気がするけど、そうでもなかったんだなぁ。



でもWEBサイト制作者にとっては朗報なんじゃないだろうか。
だってさ、正式にIE8に対応させなくても、大義名分が立つことになるんだもんな。
正直今時のサイト作成はめんどくさいよなぁ。
IEだけでも8、9、10、11、それにChrome、FireFox、Safari、スマホ系のブラウザ、などなど・・・いろんなブラウザでの確認作業が必要だったしね。
それが、とりあえず、IE8、9、10を外しても、文句を言われる率が減るんだから。

アレ?
ここで疑問なんだが、Vistaは?
WindowsVistaでサポートされているIEは9までだろ?


11入んないよね。
でもって、Vista自体はサポート中ということは?

調べると・・・
2014年8月にマイクロソフトがIEのサポートポリシーを変更し、「古いIEのサポートを2016年1月13日で打ち切る」ことにしたためだ。すなわち2016年1月13日以降、サポートされるIEは最新版だけに限られる
なになに・・・古いバージョンのIEがサポート対象外になるってことなんだな。
ここでいう、古いIEってのは・・・
それぞれのWindowsにインストール可能なIEのうち、最新版以外のバージョンのIEを指すそうだ。
例えば、Windows 7の場合、「古い」IEであるIE8/IE9/IE10が2016年1月にサポート終了を迎え、最新版であるIE11だけサポートが継続される、ということらしい。

 2016年1月にサポートが終了する「古い」IE2016年1月以降もサポートが続く最新版IE
Windows VistaIE7IE8IE9
Windows 7IE8IE9IE10IE11
Windows 8IE10(なし。OS自体のサポートが終了するため)
Windows 8.1(なし)IE11
Windows 10(なし)IE11(標準ブラウザーであるMicrosoft Edgeとは別に利用可能)
Windows Server 2008IE7IE8IE9
Windows Server 2008 R2IE8IE9IE10IE11
Windows Server 2012(なし)IE10
Windows Server 2012 R2(なし)IE11
間もなくサポートが終わる「古い」IEと、サポートが続くIEの各バージョン
2016年1月でサポートが終わる製品は赤字で記している。「(なし)」となっているWindows OSではIEのバージョンアップができない、すなわち一種類のIEしか利用できないためで、今回のサポート終了の影響は受けない。
はぁ?
難しいねぇ。
まぁ、とにかく額面通り、IE8、9、10のすべてがサポート終了するわけではないらしい。
少なくとも、VistaのIE9は生き残るわけだからな。
あ・・・でもIE8は完全終了か。
うーん・・・。
とにかく、Vista以降のOSは最新の状態にアップデートしておけよ、ってことだな、多分。

まぁ・・・いいや。
オレ、普段はChrome使ってるから。

とにかく、今後はIE8、9、10の事は、無視して良いんだな?
あ?
ダメ?
それは時期尚早??
だよな、いくらマイクロソフトがサポート対象外にするからって、お客さんのパソコンにIE8、9、10が入っている限り、対応せざる得ないだろう。

まったく・・・ホント、ブラウザは一種類に統一して欲しいもんだよ。

では。

0 件のコメント: